This project is read-only.

Unable to use owasp code crawler -error

Jun 10, 2010 at 5:07 AM

Hi,

I downloaded code crawler version2.5 and 2.7. I have also installed Microsoft .NET Framework Version 2.0 Redistributable Package (x86)

Tried running CodeCrawler.UI.exe. But when i try to click highlighted code, i get the below error. Please help.

 ************** Exception Text **************
System.IO.FileNotFoundException: Could not load file or assembly 'System.Xml.Linq, Version=3.5.0.0,
Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.
File name: 'System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'
   at CodeCrawler.UI.Forms.ChildForms.SingleFileScan.RowClickEvent(Object sender, RowMouseEventArgs e)
   at Puzzle.Windows.Forms.SyntaxBoxControl.OnRowClick(RowMouseEventArgs e)
   at Puzzle.Windows.Forms.SyntaxBoxControl.View_RowClick(Object sender, RowMouseEventArgs e)
   at Puzzle.Windows.Forms.SyntaxBox.EditViewControl.OnRowClick(RowMouseEventArgs e)
   at Puzzle.Windows.Forms.SyntaxBox.EditViewControl.OnClick(EventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at Puzzle.Windows.Forms.BaseControl.WndProc(Message& m)
   at Puzzle.Windows.Forms.SyntaxBox.EditViewControl.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Aug 4, 2010 at 1:11 PM
You have to download .NET Framework 3.5 it's on the requirements list